Issues Installing PowerShell 4.0 on Downlevel OS

PowerShell v4 is now released in the Windows Management Framework version 4.0 for downlevel OS’s, but a number of people have had issues with the install. The WMF package installs successfully with no errors, however, if you check the $PSVersionTable it does not show as v4.0. This is because the .NET Framework 4.5 is a prerequisite. This is present on Server 2012 and R2 of course, but not necessarily on downlevel machines. Unfortunately, a lot of the documentation did not originally reflect this and so customers were left confused at the end of the installation process.

The good news is that the documentation has now been updated. You can find the KB article here.

If this has affected you, you should install the .NET Framework 4.5 then reinstall Windows Management Framework version 4.0.

Enjoy.

Advertisements


Categories: Powershell

Tags: , ,

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: